想浏览器支持HTML5吗?一简单JS搞定

2016-03-06 17:04:17     浏览:

一个迷你JS脚本,就可以让你的网站兼容IE浏览器。

首先感谢remy sharp为我们提供了这个迷你的JS脚本HTML5 shiv来解决IE支持HTML5的问题.

HTML5 SHIV的调用和下载

html5.js一定要加在里调用 (因为浏览器必须先解释了这个脚本才能解析后面的html5标签,所以不能放在页面底部)

下面是下载地址:

 

http://html5shiv.googlecode.com/svn/trunk/html5.js

 

你可以直接调用这个js脚本

你可以用IE条件注释来调用这个js文件,这样像FireFox等非IE浏览器就会忽视这段代码,也就不会有无谓的http请求了。下面这段代码仅会在IE浏览器下运行:

复制内容到剪贴板

 

如果你不喜欢调用外部服务器的文件,你可以把它做成单独的js文件放在你的服务器上调用。

相关热词搜索:html5网站